Why is it so hard to find a good hosting provider?

by Natalie P.

July 25, 2013 | Filed Under The Heartless Bitch Way | 2 Comments

This site has been with Webhostinghub.com for almost a year now, and barring a couple of minor hiccups, it has worked relatively well.  Initially, support was good.

Then, a couple of weeks ago, I found that some key scripts that USED to work (and had not been changed – god knows, I’ve had no time to mess with anything), stopped working. I couldn’t diagnose it due to the limited access I have to my account at this provider (i.e. no shell access). I logged a support request, and that started a litany of nightmarish interactions that, as yet, have no resolution.

Initially they told me it was a problem with the scripts themselves – i.e. MY problem.  Oddly, some worked, some didn’t, and I couldn’t see any distinguishing characteristics between the working/non-working. The non-working ones throw a 500 error, but oddly, that 500 error does NOT show up in the error log files I have access to – so I had no details that one might normally see in the log results to help me diagnose. (One support guy actually said that was really weird because ALL errors thrown by apache should show up in the error logs).

I tried adding logging to the scripts to see if I could see why they were failing no avail.  I tried reducing one to just an output to the screen and nothing else – it still tossed a 500 error.  I looked at permissions. I looked at EVERYTHING.   So I figured maybe something in the Perl modules they use is corrupt. I tried to reinstall them.  My ENTIRE ACCOUNT HUNG – I could not log into my cpanel.  I got my account reset which got me back into cpanel (after HOURS waiting for/interacting with support), and tried to explain to them that if CPAN is hanging my entire account, SOMETHING IS CORRUPT and that I have no control over it.

I have lost count of how many support people I have tried to explain this to, and I detailed it very clearly in my ticket responses via email. While on the phone I had one support person try the install and so he could see how it hangs my account – he initially acted as if this was somehow something of MY doing.  Once again I had to explain how the CPAN and PERL installs are out of my hands – they are installed by the sysadmin team.  Another said it started forking a bazillion subprocesses just trying to do a CPAN search.  As if somehow this was MY doing. Again, I had to explain to him that I HAVE NO CONTROL over the CPAN install.  If it’s going bezerk, it’s because there is something CORRUPT in the install.  This was ALL DOCUMENTED. And yet, some “Tier 2” support person followed up (DAYS LATER) to graciously tell me the line numbers my scripts were failing on and to say that  he had “reinstalled” my perl modules for me.  And, of course, my account was hung, because he never checked to see that the modules were really installed, nor did he get to the root of the CPAN fork-storm that is a symptom of this whole clusterfuck.

(And don’t get me started on their new “support center” that requires you to log in with Facebook or Google+, the app for which requires that you give it access to your FRIEND LIST and your personal information on facebook.  Like fucking hell.)

Whereas I used to be able to talk with a support person in a few minutes on the phone, I have now been left hanging for 60 to 90 minutes (or longer) on either phone or support chat. I’ve had chat sessions dropped after waiting over an hour in queue, only to be requeued to the end of the line, I’ve had my tickets mishandled, mismanaged, and closed inappropriately without resolution. I’ve had my site taken offline for HOURS only to NOT have the problem resolved.  I’ve waited DAYS for replies on what is now surely a CRITICAL escalation.  I’ve had “manager feedback” tell me that they were sorry I had so many problems but that they were happy to see  my ticket was now resolved after I complained – to which I angrily responded that it was NOT FIXED, (and I restrained myself from using the profanity that was surely warranted at the time) and that their support team should start by reading ALL. THE. WORDS  in a ticket.    I’ve had to repeatedly explain over and over again to various support people WHY this is NOT my problem, and why it is NOT fixed just because they kill all the subprocesses in the fork-storm that blocks my cpanel login.

It’s now with their Tier 3 support (supposedly the highest) – I found this out via email after waiting 48 hour from my last escalation, and still they have no explanation of the root cause, nor any ETA on the fix.

Near as I can tell, SOMETHING changed on their servers on or after July 2nd. (the last date that some of the scripts wrote to log files). I logged my first ticket on July 11th. It’s now been 14 days and the latest response is “we have no ETA” on a fix. Give me shell access and a root account and I’d have it fixed in a few hours….

So, sadly, I may be moving HBI, AGAIN, because I’m very nearly DONE with the incompetence and poor customer support that I have received. Even in trying to post this blog entry, I’ve received random 500 server errors.  Our discussion forum is randomly available/not available, and new members cannot register for the forum, nor can existing members have a password sent to them.

I tried to use their site backup utility only to have it tell me that my 384MB was greater than the 3GB limit. (WTF?) and didn’t run properly. So I’m manually compressing and downloading everything I can in prep for the move.  (Like I have time for this kind of shit).

I’ve given them until Monday to get the problem fixed, or I’ll move to another provider (I hear hostgator is highly rated).  At this point, based on my experiences this week, I’m not holding out a lot of hope.   I don’t want to move but I can’t go on like this indefinitely….

I’ll post an update on Monday as to whether or not the site is moving and you can expect outages…

Email This Post Email This Post


Leave a Comment

If you would like to make a comment, please fill out the form below.

Name

Email

Website

Comments

 

2 comments so far
  1. Philly August 6, 2013 2:16 am

    I’m sorry to hear about your problems,I hope you’ll get your problems fixed without moving as I have this current link bookmarked.

    Anyway, here’s a link to “Best web hosting companies for general purpose hosting” (which you may already know)

    http://b2evolution.net/web-hosting/top-quality-best-webhosting.php

    And hostgator is on it, hopes this helps.

    http://www.upperhost.com/

    Here some tips on how to fix a 500 internal server error, again, which you may already know, but I’ll provide a link just in case.

    http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm

    Anyway, I hope you’ll let me know what the new web address is if you decided to change.

    Best of luck!

  2. Philly August 12, 2013 3:04 am

    So have Webhostinghub.com fixed the problems, or have you already moved to hostgator, or another provider?

    Anyway, congratulations either way!

    And I look forward to whatever new posts you may have regarding this!!!!

    Or some other Heartless Bitch article…


Your Ad Here


Allposters.com

Buy fun Heartless BitchStuff and help keep HBI running!

We now Accept

Acceptance Mark